Review of Agilent U1272A HH DMM and U1177A Bluetooth Adapter

Table of contents

RoadTest: Agilent U1272A HH DMM and U1177A Bluetooth Adapter

Author: notdodgy

Creation date:

Evaluation Type: Independent Products

Did you receive all parts the manufacturer stated would be included in the package?: True

What other parts do you consider comparable to this product?:

What were the biggest problems encountered?: Connection between PC logging program and device over bluetooth unstable, while making changes to communication settings it locked up completely.

Detailed Review:

This turned up unexpectedly this morning delivered by a UPS driver who wanted £47 cash payment for VAT and fees, because it had been shipped from the US. image

 

It may be worth making it clear to road test volunteers which country items will be depatched from as there can be charges involved.

 

Downloaded the Andriod apps and these ran fine on a HTC desire S, with a stable connection to the meter.

 

I ran a series of temperature measurements and was able to email these as a csv from the phone.

 

One small issue with the phone app are the email settings.

It does not use the email accounts already set up on the phone, so you need to enter the details yourself.

The settings possible will work fine with an ordinary account, like the gmail example, but not for my email account, which uses a none standard port.

 

I found the bluetooth range with my phone was ok in the same room, but 2-3 meters through a brick wall would not work.

 

I decided to try the PC app on my laptop, to see if that would provide a better range.

 

I found that the bluetooth connection was not stable, it would let me turn the display backlight on/off but not recieve any data from the meter.

 

(The pc speed showed as 4800 while the meter settings showed 9600).

I tried changing settings on both PC and the on the meter, but something has gone wrong on the meter.

 

Unfortunately it no longer turns on properly - it just displays "Pro" and is completely unresponsive.

 

So currently I have paid £47 for delivery of a nice looking and well featured multimeter meter which now doesn't work. 

 

I will be contacting Agilent support in the morning!!

 

Apart from the problem I have had, I think the bluetooth range could be an issue.

For some scenarios finding a way to extend this would be a definate requirement, e.g. using a tablet/phone to relay the readings. 

 

Is there such a thing as a bluetooth range extender?

Anonymous
Parents
  • I think you missed a bit on how everything gets set up. When you change the Baud rate on the meter your only affecting the comunication rate between the meter and the adapter. If the Adpter isn't adjusted as well you won't get any communication. If you want to use a differnt baud rate between the PC and the adapter you will have to go into the Hyper Terminal and use the AT commands listed in the adapter's operating instructions to change the Baud rate. I had very little trouble getting the adapter to connect and running the PC software on mine. Other then the fact i couldn't get the adapter to connect with my Win 7 system. Still gotta go back and try that again.

     

    Any time you make changes in the PC software you have to go back and click on the Data Logging button and then the play button to get the readings to diplsy on the screen again.

     

    Hope you get the meter working again. Have you tried pulling out the batteries, turning the unit on and off again then replacing the batteries?

  • With the PC connection, it looked like the connectivity was poor in one direction, based on the auto adjusted speed and that it failed to display anything from the meter.

    I had not spotted the instructions about setting speed with AT commands, so I will look into that once I have a working meter...

     

    It is currently still locked up, just displays "Pro". All the obvious actions do not reset it, including the advice from Agilent support..

     

    Because it is a road test item and sent from the US, I do not have a "proper invoice", with any numbers on it, so Farnell UK cannot trace it and the last message from  Agilent suggested that without a "full invoice" with the serial number quoted that they cannot find the /warranty information. No warranty = no replacement image

Comment
  • With the PC connection, it looked like the connectivity was poor in one direction, based on the auto adjusted speed and that it failed to display anything from the meter.

    I had not spotted the instructions about setting speed with AT commands, so I will look into that once I have a working meter...

     

    It is currently still locked up, just displays "Pro". All the obvious actions do not reset it, including the advice from Agilent support..

     

    Because it is a road test item and sent from the US, I do not have a "proper invoice", with any numbers on it, so Farnell UK cannot trace it and the last message from  Agilent suggested that without a "full invoice" with the serial number quoted that they cannot find the /warranty information. No warranty = no replacement image

Children
No Data