Quad-Channel, Analog Output Module - Review

Table of contents

RoadTest: Quad-Channel, Analog Output Module

Author: DAB

Creation date:

Evaluation Type: Evaluation Boards

Did you receive all parts the manufacturer stated would be included in the package?: True

What other parts do you consider comparable to this product?: NA

What were the biggest problems encountered?: Try as I might, I could not find a way to make the board work. A Real bummer!

Detailed Review:

First I would like to thank Element 14 and Texas Instruments for selecting me for this road test.


I knew this board was an engineering evaluation device, but little did I realize that this road test would become a design challenge.


That said, I hope the other testers have better luck with their boards than I did.


The first problem I ran into was when I did inventory of the components.

The board was supposed to come with a USB extender cable, an interface device and the evaluation board.

Here is what I received.


The first thing I realized was that there was no way to connect the USB 1.0 cable to the TI interface device.


I contacted Randall and he contacted TI, who were unconvinced that I had received the wrong cable.


So rather than enter into a urinal Olympics, my wife and I searched our copious cable collection and found the right cable.


So if anyone reading this post can figure out a way to connect the cable provided to the interface device, please comment below.  I would hate to think I missed something obvious here.


You can now see how to properly connect the USB cable to the interface.


Next I looked for the demo software on the TI site.  It took a considerable time before I finally found an "old" demo software package for the chip, but it was for an earlier version of the Quad DAC board, so I installed it in hopes that it would be sufficient to run the board.

I set up an external power source with my trusty Pico-scope and multimeter to begin testing.


Then I fired up the demo software and it booted to the following test screen.


As you can see, there are a lot of options on the GUI, but then I noticed that there was no Help file, nor could I find a users guide.

I did finally find a very terse write up in the interface guide, but I discovered that TI had recently upgraded the interface unit from an 8051 based device to an MSP430 based device.

So I was not sure if this set up would work.

With everything connected, the interface unit gave me two green lights.  The first indicated that power was available for the interface and the second was supposed to indicate that communications with the Quad DAC board was functioning correctly.


So I started probing the outputs to see if there was any voltage.

Hmmm, nothing.

I re-read the short guide and saw that if you entered a value in the GUI, it would immediately show up on the output.

So I put in a 4FFFF code, which should have provided the midpoint of my 0 to 12v DC input source.

Again, nothing.

I tried the sweep range, just in case 4FFF was midrange zero volts.

Again nothing.

So I began a systematic adjustment of all the values and buttons to see if I could get any output.




I hated to give up on the board, but there are no test points, other than the input and output connectors.

The I2C control is on a very small connector and I did not have any clips that would fit on the connector without shorting it out, so I could not verify that the interface board was correctly controlling the DAC chip.

So very reluctantly, I decided it was time to stop.


On the plus side, the board is very well made and I really liked the addition of the little plastic feet on the board to keep the bottom traces clear of any short hazard.


On the down side, well, try as I might, I could not make the board do anything.

I was quite disappointed as I have used TI boards for over forty years and have always found their support excellent.

I hope this test is an anomaly and not an indication that TI quality might be falling.


I will make one caveat.  I am suffering from a form of ADD and I entered this test to see if my condition had abated with new medication.

Good news is that it was better, but evidently I have not improved enough to decipher how to make this board work.


If any of the other testers have better luck and can provide me with some hints, I will revisit the board and update this review.


I had hopped to use this board for some upcoming research experiments I have planned, but for now, I will have to look other places for the tools I need.


Thank you for reading,



  • Don It is sad that there is no obvious support for this, but I did see this note in the RT page.

    This product is a specially built reference design for this RoadTest that is not available for purchase. Hence is a unique opportunity to review.


    It would appear that there are some links that look like normal text and one of them took me to this page.


    The hardware looks different, but it does use the same chip and it seems some of the descriptions match the GUI picture.




    On page 9 it clearly shows the cable required, so maybe someone needs to order TI some new glasses.





    Looking at the GUI picture you posted, there was one selection box that you might have overlooked (or maybe you tried it)


    It does read that "once enabled" you can enter values, and a reasonable person might expect that unless the output is enabled it would refuse entry, BUT I've seen all sorts of software and sometimes it represents what you expect, and other times .....


    Perhaps if you have time you could try it again and grab a snapshot of the GUI with settings that you believe should work.

    Jan may be able to duplicate it and verify if there is an issue.



    Hopefully someone in TI takes note and makes contact.

    I was very impressed by Infineon and their response to the Motor control issue one tester found.

    Their example of support needs to be emulated by quite a few others.



  • Hi Mark,


    I tried all the combinations of buttons and data I could think of.

    That does not mean I did not miss one, but I tried to go over this thing as best I could.


    Yes, I did find that older manual, but as I said, that SMU device was an 8051 controlled processor.

    The new one is MSP430 controlled and I am not sure that they are plug and play replaceable.


    I have not given up, I have moved on to the PIR sensor road test, which unfortunately also requires some design effort to get working.


    Have no fear, I will keep plugging away, but I really do want to see what the other road testers ran into.

    If it is just me, I can accept that, like I said, this was a test.  Maybe it is time for this road tester to ride off into the sunset.



  • Hi,

    Perhaps this information can help:
    Two years ago I ran into problems installing the unsigned TI driver software into the Windows operating system.

    That was with the Windows 8.1pro. -> Also with the Win10.
    I had to first release the lock in the operating system, so I could then install unsigned drivers.

    TI didn't inform me about this behavior. They sad (the support), "all working fine..."

    The problem can be that the SM-USB-DIG is not installed correct.


    1) go to the command line, type:


    shutdown.exe /r /o /f /t 00

    -> the PC will restart showing the option menu

    2) go to the menu item - Problem service, or similar...

    3) go to Advanced Options

    4) go to the meu item Startup settings, or similar...

    5) select the item -  Force, disable driver signature (in German that was the item 7)

    6) restart the PC.


    After that in the Windows OP you can now installing the unsigned drivers

    - If you have some questions during installing: "there are unsigned drivers, install it or not?" ->> YES!!


    I think too, that the installed GUI does not match with your hardware completely. As you mentioned that you found an old GUI.

    If the communication works, does the LEDs ("data") flashing? Can you see something with your oscilloscope?


    I hope this may help.


    Best Regards,



  • Hi Gerald,


    I ran the procedure to load the drivers and the software claims it can see the SG-USB-DIG.

    I did not see the lights flash to indicate that the serial transfer occurred, so I suspect that there is a problem between the GUI and the interface.


    Once I get some time, I will go back to search through the issues and hopefully resolve the problems.




  • Hi Gerald,


    I ran the procedure to load the drivers and the software claims it can see the SG-USB-DIG.

    I did not see the lights flash to indicate that the serial transfer occurred, so I suspect that there is a problem between the GUI and the interface.


    Once I get some time, I will go back to search through the issues and hopefully resolve the problems.




No Data