TI Multi-Node IoT Bundle Roadtest - Review

Table of contents

RoadTest: TI Multi-Node IoT Bundle Roadtest

Author: phoenixcomm

Creation date:

Evaluation Type: Independent Products

Did you receive all parts the manufacturer stated would be included in the package?: True

What other parts do you consider comparable to this product?: I have used the Araren ZigBee module, but they have their own MSP430 on the module. So if this RoadTest used that product, I could have put the module directly onto the CC3200 module. Also, they are a mesh system, and not proprietary.

What were the biggest problems encountered?: The Air Module CC110L requires an MSP430G LuanchPad, as the Air Module has a replacement, reprogrammed MSP430 for the LuanchPad. The MSP430FR5969 has no removable CPU. In addition, to make the kit of parts that we received, to work there should have been two (2) MSP430Gs.

Detailed Review:

An Araren Air Module installing on an MSP430G
Figure 1
MSP430FR5969
Figure 2

When I opened the box. I found the following: CC3200-LAUNCH, MSP430FR5969 (Figure 2) and CC1100L Air Module. After reading the Air Module Instructions and looking at the MSP430FR5969 for the  second time, I knew that we were in for some fun and games.  After a quick call to Anaren to double check and to find out that the CC110L Air Modules will only work point to point and they utilize proprietary software, and that the MSP430 LaunchPads CPU must be swapped out for the MSP430 that is provided in the Air Module (Figure 1). This meant that the Air Module requires the MSP430G LaucnhPads and you would need two (2) of them, one for each of the Air Modules.


672

My Roadtest Block Diagram

Figure 3

So that leaves this Roadtest looking at it one way as a bust!


But what do I see in my TI Goodie Box, why it is two of the MSP430G LaunchPads!! So lets the games begin!

If you look at Figure 2 you will see that my goals are as follows:

 

Phase 0: Getting CCS6 installed on my Linux Mint 17r2 box. Nov 1, 2015 Just this took 1 1/2 months!!!

Phase 1: Getting the C2200-LAUNCHXL to talk to my WiFi network. I don't use DHCP as it is easier to troubleshoot.

Phase 2: Getting an MSP430G to talk to the C2200-LAUNCHXL via I2C

Phase 3: Replacing the MSP430 CPU and repeating phase 2.

Phase 4: Repeat Phases 2 & 3 with the second MSP430G

Phase 5: Verify that both MSP430Gs can talk to each other via the Araren Air Modules.

Phase 6: Install the DHT11/22 Temperature / Humidity Sensor and print out values every 15 seconds, as well as the last time the fans were on. The DHT11/22 is a raw device so there will be some work there. (There is an application of this part working on an Arduino.)

Phase 7: Verify that I can command the remote MSP40, to turn on - off various outputs and read the inputs.

Phase 8: View, and control environmental functions from the Kentec QVGA Display Board

Phase 9: Command the system from the Internet, and or a smartphone.


My goals are currently RED when that task is completed I will turn it GREEN.


Most of the TI software requires Microsoft Windows (the software is packaged as a windows installer). I finally got the software unpacked, I really don't know why they just didn't provide it as a damn zip file. Aside from that nonsense the TI documentation is normally spot on.

Getting CSS6 to support Linux was painful. On early installs both the App and Help centers just went away or blows up Chrome. With both more installs and updates, this was finally fixed. Getting Simplelink and the CC3200 was  painful. There was a missing add-on 'CC3200 Support Package'. This was a problem with 6.0, 6.01x which caused more reloads and installs. Finally in 6.1.1.00022 they added CC3200 into the installer. There was no problem installing the MSP430 components, just as in my old CCS5, that was on my laptop that was stolen.

 

UPDATE: 11/7/15 As of this writing both the MSP430 and the CC3200 built in USB debugging are supported in this version of CCS6 with Linux.  Ti's e2e is kind of worthless. I have a call into TI Austin's Technical Support and have an open tick on the CC3200, I will have to add the MSP430's as well. The MSP430 was recognized by Energia16.

There seems to be a workaround. There is a program MSP430DeBug  that is claimed to work. I installed it but no luck it can't seem to see the MSP430 eather.

So at this pointI'm calling this a RoadTrip a bust!!

I will continue to update this site.


UPDATE: NOV 16, 2015 There was a sad tail of woe trying to program the MSP430G2 with the USB debuger which is built into CCS6, as it is NOT SUPPORTED under Linux. But wait there is a solution it is to use the MSP430FR5969 which was part of our kit, as a in-circuit debuger with the target the MSP430G2 by using the JTAG interface and a software product called EZ-FET. There is a great write up in the TI e2e Comuminty: MSP-EXP430G2 Launchpad, Linux, CCS, one solution that works

Anonymous
  • Hi, Trey.

    > Yes, I had LOTS of problems with my road test and CSS6. My environment is Linux Mint 17r2 64bit Cinnamon. I do not have any MS components or Wine installed. I have been using Eclipse for some time and I had CCS5 or 4 on my old laptop (no more), I already had Chrome installed as well. The first time it was installed the help and app centers vanished! or Chrome would Crash, or both. This was finally fixed with a new release and updates. > Question why put a zip file in a Windows installer??? And not just supply the zip.

    > Why do Ti engineers that are supposed to help just push customers to e2e when most of the time they (e2e) don't have a clue. It's like the blind leading the blind.

    > Considering that CSS has been built on the eclipse platform, which is open source, why hasn't Ti supported the environment? In the embedded space most of us use a small lite weight OS/dispatcher. Only Intel is pushing an "embedded CPU" that supports Windows. Yes, you can run Windows on your Pi but for real-time control, and home and factory automation you don't. The Windows environment is not friendly to lots of I/O, ie just no native support.

    > You mentioned Energina / Arduino IDE - or the Sketch IDE. I, for the most part, am working in real-time flight simulation. I have found that Sketch is broken. It's maybe great for teaching like Pascal was, for getting ideas across. And is less intimidating than having to use, and understand an IDE like eclipse. But for ease of use, you give up a lot.  And a large system like a simulator will not work. Please see: http://www.element14.com/community/people/phoenixcomm/blog/2015/08/21/nexgen-software-development-arduino-sketch-eclipse-on-linux

    > Consider that Linux and Open Source is like swimming you don't just stick you toe in. No, you jump in feet first.

    Thanks, Cris H. (Fort Worth, Tx)

  • We’re disappointed to hear you had a bad experience with these boards and want to make sure you’re successful with your project.  I noticed you tried Energia late in the road test.  In our experience this is the best tool for new LaunchPad users to get started. All of the boards in this road test are supported in Energia, which should make completing your project a snap!  Have you seen this tutorial on Hackster?

    https://www.hackster.io/elephino/cloud-connected-subghz-rf-star-sensor-network-0e6c61

     

    If there is anything we can do to help you out moving forward let us know! 

    Best Regards,

    Texas Instruments

  • Same.. Asked info about the AM3715 Pop memory didn't received appropriate answer from Ti's e2e.
    On the review part, I believe they should provide the kits in pair(if there are some Bluetooth or any Mhz/Ghz module associated) with proper tools.

     

    Good Luck for the Next..

  • Hi Cris,

     

    Sorry to hear your laptop was stolen : (

    Horrible when anything like that happens.

  • In recent years, TI has tried to push support off onto their e2e forum.  Nothing bugs me more than not being able to call up my local apps engineer and ask him my question.  If he doesn't know the answer and wants to post a question to the forum, fine.  But don't push that work off onto your customer (the engineer designing your part in).  The few times I did post a question to e2e, I either didn't get an answer or got the wrong answer.  So, I wholeheartedly agree that e2e is pretty much worthless.  From speaking with my co-workers, it seems that TI support in general has taken a nose-dive in the last few years.