TI Haptics Enabled Gaming Controller BoosterPack

Table of contents

Haptics BoosterPackThe HapTouch BoosterPack (BOOSTXL-HAPTOUCH) integrates capacitive touch functionality with haptics technology in a single TI BoosterPack.  Designers and Hobbyists alike now have the ability to develop applications using two of the hottest technologies available on the market today.
The HapTouch BoosterPack includes allows users to evaluate and begin designing with the included Immersion Technologies software and onboard ERM and LRA motor/ actuators on the board. This BoosterPack features MSP430TCH5E haptics controller and DRV2603 haptic driver.
Demo and configuration software is also included to configure over 100 haptic effects as well as help users try out the BoosterPack on their own PC.
Things you can do using HapTouch Booster Pack:
  • Experience tactile feedback with haptic (vibrational) technology.
  • Play PC games with Capacitive Touch and gaming controller
  • 122 haptic effects featuring industry leading haptic technology from Immersion – Royalty free
  • Effect sequencing for cool machine gun, heart beat and dice sequences
  • Feel the music with Audio2HapticsTM technology
  • Evaluate with a motor-based (ERM) or spring-based (LRA) actuator
  • Full programmability with JTAG emulation and software development kit
Terms & Conditions
  • Testers will be selected on the basis of quality of applications: we expect a full and complete description of why you want to test this particular product.
  • Testers are required to produce a full, comprehensive and well thought out review within 2 months of receipt of the product.
  • Failure to provide this review within the above timescale will result in the enrolee being excluded from future Road Tests.
Reviews for this Roadtest
Comment List
Anonymous
  • Where can I download HAPTOUCH sdk for now ?

  • This is just an amazing product. I had awesome fun using this, and even more fun as an engineer ripping it open and playing with it.

  • Update: i finally made it work under Win7x64, but it still doesn't have the full functionality. The audio feedback still doesn't execute and more debugging is needed. It's not hard to configure the controller, it's just takes time to understand the commands and configure some of them. Hope i get all the functions to work well.

    Update: as gaming joystick, it performs almost flawlessly with no delays. Game tested: "street fighter".

    Update: audio haptics alive and kicking. not much to say here. i'll be posting full review soon.

  • I did:  - installed VM10 and then winxp sp3

              - installed EZ430-UART drivers from Energia folder

              - then plugged the booster-launchpad

    As in win 7 x64, in the xp, the same msg appear "ERROR communicating to COM port MSP430 Application UART". (p.s. in xp the GUI loads in about 1 min)

    P.S. - i did uploaded a blink example on the launchpad to see if there's a difference of behaviour. The launchpad works fine with energia, but the boosterpack is alien-ware to me. I just can't get it to work. UHHH!

    P.S. - Well at least i found out why GUI lagged after installing VM workstation

  • Hi Alexe, It finally worked for me Yuppieeee...ee.. Ya u are right the GUI Is really crap. Which OS Are u using ?

    I Installed WinXP over VM Ware and installed the MSP430 Launchpad's ez430 Drivers included in Energia. That did the trick and now everything is working as it should be.

     

    I would suggest u Try opening the COM Port using a terminal application and "9600 baud" and then send the cmd packet "0x6 0x54 0x0 0x0 0x0 0x0 0x1 0xd" you should see a response of 0x01 and the RED LED on the Launchpad will glow this means that the communication is working and your msp430 Launchpad is properly programmed.

     

    P.S. I will soon push all the drivers and documents which I will create onto my github repo. and hopefully by next week complete the review

  • Hi Gill. I finally got my launchpad and began testing the haptouch addon. The boosterpack works well when connected to the launchpad, just as touch/feedback device, well the story gets complicated when trying to use the GUI which it's too stubborn to communicate through UART. Got this error everytime even after setting up the launchpad exactly accordingly to the haptics instructions manual. ("ERROR communicating to COM port MSP430 Application UART (COM5) 'No response was received after waiting for 2000 milliseconds.', CMD: 0x6 0x54 0x0 0x0 0x0 0x0 0x1 0xd").






  • Hey Miron, an update from my side, the hap touch GUI Doesn't work with my Win8, but i recently tried it with a winXP installed on my VM, and it does work the gui loads up within seconds and basic communication work. I am able to get some simple vibrations on my BoosterPack by sending data through UART.

    Though while assigning a gaming profile the software tries a total of 8 sequences of commands one for each key to assign the values to the BoosterPack, but it seems a bit buggy, In my case the first sequence is successful but the software crashes there after. I have tried to send commands manually through a terminal app (The baud Configuration is 9600) and it works fine but the app have some issues. I tried to look its source  (C:\ti\msp430\MSP430HapTouchSDK_1_10_00_00\guicomposer\webapps\HapTouchGui\app.js) but its Javascript and the app is written in django i suppose, which i do not know. so maybe if u know u can look at it ?

  • As i suspected there's something wrong with my OS sys files. I have a win7 x64 bit platform desktop computer that loads the gui in about 3 mins. I've tested the GUI on a laptop (x64) and a desktop x32 and on booth of them the GUI program loads instantly. In conclusion there's nothing wrong with the GUI, it's just my desktop computer's problem. Still waiting for my launchpad to arrive, found it on a third party supplyer. Will keep you up to date to any news that will come up.

  • @Miron Yes it takes a while to load, but not as long as 3 Min, Mine takes Approx 1 Min to load for me. and sometimes when i start the app , i have to remove the Launchpad USB and reconnect in order for the GUI to detect the Device.

     

    Once the Launchpad is detected, I click the send command button and BOOM, the Status Indicator changes the color to red and nothing works..

     

    Did u got any success with the GUI ?

  • @Gill, did you experienced a long load time of the HapTouch Gui program? Mine loads completley (it's components like menus and options) in about 3 mins and 20 sec. Does anybody else had this problem?