Microchip Curiosity Development Board - Review

Table of contents

RoadTest: Microchip Curiosity Development Board

Author: geralds

Creation date:

Evaluation Type: Evaluation Boards

Did you receive all parts the manufacturer stated would be included in the package?: True

What other parts do you consider comparable to this product?:

What were the biggest problems encountered?: No USB cable. USB driver. Controller was not correctly plugged into the socket. Spacer sleeve is missing under the target socket on the bottom site of board.

Detailed Review:

Hi,

Thank you again for selecting me for testing the Curiosity Development Board.

--
My Review:

Curiositiy - "Hello World"

First: (05.01.2016;; so 1'clock in the morning)

the Board comes without a cable. - This is a little bit tricky, but ok, this was written by microchip's website.

The power connector is an older type - mini USB-B . So, please do not drop this old kind of cables, because the Curiosity Board needs this.

Well, this board is so sweet, i like it.

- Than i connected on the PC - wow, the LEDs are lighting, even i pressed the buttons, the PWM with POT1 works. - done; the µC works.

"Hello World!""I'm living".

 

Second:
(I installed the newest IDE - MPLAP X 3.20, because i finished  before an old project... ) - all is now clear, jung and fresh.. ok..
I connected the IDE (button "refresh debug tool status") to the board, but this not worked. There was no message, what wrong, nothing.
Ok, // ? USB driver?? - Yes, this was one of the errors, firstly.

I connected the IPE / Programmer/to the board, selected the right controller,
than the programmer updated the board-firmware. and USB driver.

Done! - the board can talking with the IPE.
But i got an error message " the target device-ID does not correspond with the connected device".

Than i conneced the board to the IDE, but in the IDE was the error again; no board, no target device.
Ok... good night, i'm tired.

 

Third:
Today, - I restarted the PC
Than optical i searched for an error. May be ...
Yes i found the error:
The µC was not plugged correctly into the socket. well well...

So, i'm tried all again.. and... tada! all is on, connected, and working.
Done "Hello world".

 

 

Important:
1) A 6mm spacer sleeve has to be stuck on the bottom site, because the board and the wires may break.

2) Do not forget, some dualline-connectors and jumpers have zero ohm resistors on the bottom site!

Unsolder it, if you use the connectors.
/what's an idea....?!?!/

 

 

 

Question:
P1 - why are the drillings not in line? May be, the developer can tell me what was the idea.

 

And the R26 is very close to the P1.

 

 

Summary:
at the moment, "for quick jump and play" i tried also  a PIC12F1840.
May be this device ist not supported yet, or because the error what i had yesterday.
While the PIC16F1619 was not found by connecting, so i tried this known and programmed device PIC12F1840.

On microchips website there is a list about supported controllers, including PIC12F1840. hhmmm....
http://www.microchip.com/pagehandler/en-us/family/8bit/devboards/curiosity.html

 

Summary, the Curiosity Board is a fine small board with that you can make fine projects.
Look for some reasons every time on both sites (top an buttom) of the board!
There are some tricky things with that you can damage your board also the target device and its circuit.


Good luck!
Best Regards
Gerald
---

Anonymous