MAX31889EVSYS# Temperature Sensor Eval Board - Review

Table of contents

RoadTest: MAX31889EVSYS# Temperature Sensor Eval Board

Author: mstroehle

Creation date:

Evaluation Type: Development Boards & Tools

Did you receive all parts the manufacturer stated would be included in the package?: True

What other parts do you consider comparable to this product?:

What were the biggest problems encountered?: SD Card Logging Feature did not work, After connecting a battery I have bricked the device.

Detailed Review:

From Unboxing to Value on the display in 5min

 

 

 

 

 

I have installed the MAX31889EVKitSetupV125.exe which I've downloaded from maximintegrated.com without any errors.

After installation I've connected the MAX32630FTHR with the "Hat" "MAX31889 EVKIT A". Although the manual said "Do not start the application bevore connecting the device" I did and it worked very well.

There was no configuration neeeded. The Temperature value appears at the screen. This was a very easy exercise.

 

 

 

From "On the fly SD Card Inserting" to "No way to get it worked properly"

 

I expected that the SD Logging Feature will work the same intuitive way as  displaying the Value.

 

I inserted a SD Card and there was no change at the Statustext: "no SD Card inserted"

Clicking a few times on the "check status" Button does not change anything

 

So I tried to close the GUI, resetting the device and rebooting the computer in a desperate fashion.

 

I did'nt find any information about the SD Card so I tried to format it to different FAT Formats.

Again no successs. I decided to use different SD Cards. All of them didn't work.

 

Maybe the SD Card Holder is a very strange one and I have to insert the SD Card upside down? The Status message changed to ready.

 

But this was just an misinterpretation because the Function of the SD Card Feature is just Random.

I checked the SD Card Slot again and I can now be sure that the correct orientation is the orientation which I inserted at the beginning. It's typical for all SD-Card holder that the Pin Area directs to the PCB.

 

Finally it worked for a few minutes: The led is blinking red. Bevore it was blinking orange approx. 3 to 5 times.

So I tested it while it was connected and powered by USB and I expexted to collect about 30 values

After using the GUI function "saving to file" I opened the CSV just the time and no temperature values were logged

Directly after repeating the procedure it worked and time and temperature data were display.

This Feature is a litte bit mysterious and another run with a new SD Card (32GB Samsung EVO) was indicated.

Again random and not absolute not repeatable errors occured.

 

I decided to order a battery with the right connector and postpone the test of the logging function.

 

 

 

 

Calibration at room temperature

 

Outside the climate chamber I've calibrated the sensor at approx. 25°C with an expended measurement uncertainty of 0,79°C.

 

 

 

T(REF) / °CT(DUT) / °C ΔT   / °CU / °Cremarks
24,725,831,130,79outside the chamber, compared on the desk in a climated room.

 

The reference thermometer was calibrated at an accredited calibration lab. (Traceable to SI) in September 2020.

Of course this is just an indicator of a single point calibration and not an eligible way to calibrate these kind of sensors.

Unfortunately this was the only date I've collected. The reason you can read below.

 

The end of the evaluation board

 

Meanwhile the climate chamber temperature and humidity reached a steady state.

Perfect time for another try to check the Logging function. I have planned to use the logging function to calibrate the Sensor because I the temperature steps are high enough to easy compare the temperature values of the DUT and reference.

After connecting to the battery to the boar all LED's stay dark. Did I forget a jumper? Like in a rush I disconnected the battery and  read through the Documents quickly. But there was no critical step I missed. I expected that the brand new battery is dead and

power by USB will light up the beautyful LED's again. Unfortunately not. It looks like the device is dead.

 

Result

 

Unfortunately I was not able to perform a full calibration of the sensor. I wanted to test the hardware at the full specified temperature range. But it never went into the chamber. The GUI Software was really easy and inuitive. Thats what I am expection when I am ordering a Devkit. This worked very good. I have no clue why the SD Card is not working but I am not the only Roadtester who had these kind of problems.

Anonymous
  • Battery polarity is a potential issue-

     

    Feathers use a flipped polarity, as well as Adafruit batteries-

     

    "We can guarantee our batteries work perfectly but we cannot guarantee for 3rd party ones"

     

    I've recommended to reflash firmware.

  • Could it be that the battery's polarity was reversed? I once ordered a batch of jst headers with wires attached then soldered those to a battery and almost plugged them in a microcontroller. Good thing I double checked the polarity because the batch of wires had black and red reversed! It's possible this is also what happened.

     

    In this case, maybe it's just the microcontroller that's busted and the sensor itself is still okay? Are you able to work with something like an Arduino to integrate with the sensor?

  • It sounds like the technology here is not ready for prime time.

     

    DAB