I'm designing two classes, for a stepper motor project:
- one can send commands to a stepper motor.
Each command has the number of steps and direction
Running the motor happens async. Once the first command is sent, the motor heads off, until all commands are done.
I named it stepper - the other class does the same, but it can notify the caller when it has completed a command.
I named it stepper_interrupt
I'm not happy with that second name. It doesn't show what the class does. It's named after how it does it. I don't like that.
Do you have a better name?
please don't call it Stepper McStepperFace