TI C2000 InstaSPIN™-FOC LaunchPad w/ Motor Driver - Review

Table of contents

RoadTest: TI C2000 InstaSPIN™-FOC LaunchPad w/ Motor Driver

Author: Anonymous-237891

Creation date:

Evaluation Type: Evaluation Boards

Did you receive all parts the manufacturer stated would be included in the package?: True

What other parts do you consider comparable to this product?:

What were the biggest problems encountered?: Nothing yet apart finding a suitable motor. The example code for the Piccolo board was just fine, but it is missing examples for the expansion board. Sad.

Detailed Review:

Unpacking and first impressions


My package arrived a bit late, I hope I won't be banished from road test just because of some delay in shipment.

Anyway I was super happy to crack the thing open, but I got disappointed when I realized this kit doesn't include a blcd motor.

I'm not involved in quadcopter making and this sort of things so I don't have any of those laying around.


The box came with everything need to get started (apart from the motor ) but the usb came with it so, I'll call it a "nice touch".




Installing the software


The software needed to code the board is all free and UNLIMITED that's really nice from ti (big thumbs up).

The two software need are:

CCS(code composer studio): http://processors.wiki.ti.com/index.php/Download_CCS

ControlSuite: controlSUITE - CONTROLSUITE - TI Software Folder


After install CCS should look like that

And ControlSuite like this

The drivers (thanks god) got installed with CCS but to make sure they work as intended, I just double check my computer/manage/devices.

(Yes sorry my Windows is configured in French)



Playing with the demo application


As explained in the quick start guide (http://www.ti.com/lit/ml/sprz413/sprz413.pdf) you can run the two demo allready programmed on the board.

The first is the very mainstream blinky led application. But the second one is much more fun to play with, it does measure the internal temperature of the chip and the send it over serial.

To do this they recommend using Putty (PuTTY Download Page) wich i did. (with the following settings)

And then You get the temp on a terminal (nothing fancy but still rewarding)

The board also show you on 8 bit the delta temp measured with the starting temp of the microcontroller. Sorry for the blur on the picture my camera doesn't like those LED that much.

 

Here I am again...

I haven't make anything turn yet but I am not giving up with this, I will someday.

 

For now I have learn how to download code onto the board, I am quite proud of this and I also experimented around with the board to get better with it.

 

Downloading the exemple code was not that hard.

And the debugging tool was just fine.

You have access to all needed register ect... Basic stuffs here.

I was quite disappointed though not to find any example code related to the expansion board, which is quite a shame because other expansion board are supported with example code and all the good stuffs.

But anyway the output of the terminal leaved a good impression of the board.

 

I will finish the review once I get the motor to spin ... Hopefully I will make it to that point

Anonymous

Top Comments

  • Hello Benjamin Bonnal,

     

    I got a response from TI and they mentioned I should look at the document linked below, it resolved my issue I am now trying to get some other demos working.

    http://e2e.ti.com/cfs-file.ashx/__key/communityserver-discussions-components-files/171/7776.C2000_5F00_launchpad_5F00_ba…

     

    As for getting more help with the C2000 I was suggested to look at this link, which I have a feeling you have already done.

    C2000 LaunchPad - Texas Instruments Wiki

     

    I have found a list of other links that I will look over but that all depends on what time permits.

     

    Kas

  • So was I when I received the board.

    But the extension board wasn't that great at all at the end. It is a basic BRV controller really similar to the one used for stepper also made by ti.

     

    By extended PWM controls you mean ? I didn't noticed this board had such special features.

    I actually had to make for a class at school a Systick handler for servos in assembly language and it was a real pain so I try to deal as little as possible with PWM but I will sure read your review and take inspiration from it to learn new stuffs.

     

    Thanks for the rating I really appreciate it. It makes me want to dive in again a continue the review. Hopefully I will get the software to work again (fingers crossed)

  • Good review

     

    I am very interested in your assessment of the C2000.

    I have one, but have not yet had time to put it to the test.

    I was very interested in the expended PWM controls.

     

    DAB

  • Hi, unfortunately my PC quit working a few weeks ago and I don't had time to reinstall that particular software so I don't remember how I handled this issue.

    But I can already tell is that I had the very same issue or very close to it.

    Just in case (I am pretty sure you already checked all this but I'll make a list anyway):

    -do you use the provided project exemple founded in Ti ressource explorer, using the whole project instead of only the source solved quite a few issues.

    -are the switches all in their right positions (mine are all up)

    -under computer/manage does everything appears to be fine (no unrecognized devices/ports)

     

    If you don't have uploaded any code it means it still have the demo code on it, so did you tried putty ? Make sure under session you selected serial

    Putty_settings.png

    (image is from the web but ssh should be ticked)

    The port COM should appears in the manage window if all the drivers are installed.

     

    Maybe the exemple code already worked on your board but you didn't mentioned it on your comment so I was not sure.

     

    If all the previous steps worked it means the debugger chip on the board does emulate the port COM which means you are not far from getting it working.

     

    In CCS you will have to play around a bit with project/edit preferences or so... and make sure in the debug tab that you have the debugger configured right.

    Also you have to close putty, it will interfere with CCS debugging because it obviously uses the COM port while you try to use it in another software.

     

    Finally you can maybe try going into computer/manage/port COM  and edit the preferences on the port present in that list, the preference of the particular port you have your board plugged give you the possibility to change the baudrate value. Change it to 115200 it will maybe do something.

     

    I will if you are still stuck download CCS again and do the whole process again to see if I can get the error showing up and try to fix it.

    Until then good luck. And please in the next comment, list what does work so I can help you better.

     

    Hope it will help, but really if the demo that is already on the board works it makes your problem very strange.

  • Hey Benjamin Bonnal,

     

    I see you where able to get code to load into the C2000, would it be possible to explain what you did. I am constantly getting errors. I have tried CCS v5 and v6 with no success. The Errors I am getting are:

     

    CCS v5

    Can't Initialize Target CPU:

    **Error**: Serial Communication failed at port: COM65, baud rate:9600!

    To use serial monitor, please ensure the following prerequisites are satisfied:

    1. Make sure the cable is plugged into both the target and the host on the right COM port.

    2. Make sure a compatible target side serial monitor is loaded and running on the target device.

     

    - For this error I'm not sure about port 65 as it does not exist in the device manager...

     

    Source Lookup: unable to restore CPU specific container - expecting valid source container id value

     

    - Not sure what this error means...

    CCS v6

    Missing new Target configuration (not exact error)

    - I tried fixing this by suggesting the uC being used and the connection (TMS3208027 - UART Connection)


    After fixing the COM port to the correct number I get a new error:

    C28xx: Flash Programmer: Warning: The configured device (TMS320F28027), does not match the detected device (). Flash Programming operations could be affected. Please consider modifying your target configuration file.

    C28xx: GEL: Error while executing OnTargetConnect(): Could not read register ST1: Execution state prevented access at (ST1&~(0x0100)) [f28027.gel:272] at C28x_Mode() [f28027.gel:80] at OnTargetConnect() .

    C28xx: Failed CPU Reset: Unsupported GTI Function.

     

    I haved also seen this with v6
    Can't Initialize Target CPU:

    **Error**: Serial Communication failed at port: COM65, baud rate:9600!

    To use serial monitor, please ensure the following prerequisites are satisfied:

    1. Make sure the cable is plugged into both the target and the host on the right COM port.

    2. Make sure a compatible target side serial monitor is loaded and running on the target device.

     

    All the demo codes compile the issue is getting them to run on the launchpad, any help in moving to this next step would be very much welcomed.

     

    I will also try post these questions on the TI forum as well to see if I can get something working here...

     

    Thanks

    Kas

  • hi,

    Thanks a lot for the compliments...

    In fact, I just followed the basic demos and tutorials to have something to show for the review until I get something to work.

    The hardest part was to be able to flash code on the board from ccs, I had hard time figuring out you had to Debug to get the code flashed onto the target device.

    That is wierd, very different from Keil and AVR studio which separate the flashing tool from the debug mode.

    And configure the target board was akward, I didn't noticed the board was an "experimenter's kit", I choosed the debuging chip as the target device at first and got a bunch of errors that didn't explain what was going on.

     

    But unfortunately I am back to the start because my computer had a fatal crash yesterday. I whyped everything out to get a clean reinstall of windows.

     

    I would love to share everything I can with you. If you get stuck I would really enjoy helping you out (if I can).

    I'm no expert, just a random motivated student.

     

    For my "notes" I am confused since I lost everything apart from the picture which appears to be sync with my dropbox

     

    Sorry for the crappy english. (I do speak French a lot better though)

     

    -Ben

  • Nice start to your review, I like that you won't let the board or lack of motor get you down . I am in teh same road test and the issues you are haviong sound very fimiler. I am finishing up another project and hope to get on this one ASAP. If you want to colaborate (two brains are sometimes better than one, I would be happy to compare any notes we may have to see if we can progress through this board at a nice pace.

     

    Kas